aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-07-22 22:15:21 +0000
committerEric Andersen <andersen@codepoet.org>2003-07-22 22:15:21 +0000
commite5272074c9bf554fa9f24a97899de584b1c127c2 (patch)
treeb2cb25c7af226c471111fd04f14e7502f41b1155 /debian/rules
parent20c9f1e5e7290c7d22bdf4217e66b9d75e9e73df (diff)
downloadbusybox-e5272074c9bf554fa9f24a97899de584b1c127c2.tar.gz
eliminate DOSTATIC, DODEBUG, etc and name them sensibly
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 5 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 47605fa71..82bf9f04a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
VERSION = $(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2)
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- DODEBUG = true
+ CONFIG_DEBUG = true
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
@@ -39,7 +39,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
install -d install-$(PACKAGE_PREFIX)/bin
install busybox install-$(PACKAGE_PREFIX)/bin/busybox
@@ -57,7 +57,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
install -d install-$(PACKAGE_PREFIX)-static/bin
install busybox install-$(PACKAGE_PREFIX)-static/bin/busybox
@@ -75,7 +75,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
$(MAKE) PREFIX=$(CURDIR)/install-$(PACKAGE_PREFIX)-udeb install
@@ -89,7 +89,7 @@ ifneq ($(wildcard ./debian/config-net-udeb-$(DEB_HOST_ARCH)),)
cp ./debian/config-net-udeb-$(DEB_HOST_ARCH) .config
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
$(MAKE) PREFIX=$(CURDIR)/install-$(PACKAGE_PREFIX)-net-udeb install
endif