aboutsummaryrefslogtreecommitdiff
path: root/debianutils/Makefile.in
diff options
context:
space:
mode:
authorDenis Vlasenko <vda.linux@googlemail.com>2006-10-05 10:17:08 +0000
committerDenis Vlasenko <vda.linux@googlemail.com>2006-10-05 10:17:08 +0000
commit7d219aab70e6951ab82c27c202cac05016696723 (patch)
tree4c0679bfa391f71aee9b51505a5d3dc8f60a0cf7 /debianutils/Makefile.in
parent8f8f268cfdecb4cabeb2e649a73afc7a485aeff5 (diff)
downloadbusybox-7d219aab70e6951ab82c27c202cac05016696723.tar.gz
build system overhaul
Diffstat (limited to 'debianutils/Makefile.in')
-rw-r--r--debianutils/Makefile.in33
1 files changed, 0 insertions, 33 deletions
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in
deleted file mode 100644
index 2983565b8..000000000
--- a/debianutils/Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
-# Makefile for busybox
-#
-# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
-#
-# Licensed under the GPL v2, see the file LICENSE in this tarball.
-
-DEBIANUTILS_AR:=debianutils.a
-ifndef $(DEBIANUTILS_DIR)
-DEBIANUTILS_DIR:=$(top_builddir)/debianutils/
-endif
-srcdir=$(top_srcdir)/debianutils
-
-DEBIANUTILS-y:=
-DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o
-DEBIANUTILS-$(CONFIG_PIPE_PROGRESS) += pipe_progress.o
-DEBIANUTILS-$(CONFIG_READLINK) += readlink.o
-DEBIANUTILS-$(CONFIG_RUN_PARTS) += run_parts.o
-DEBIANUTILS-$(CONFIG_START_STOP_DAEMON) += start_stop_daemon.o
-DEBIANUTILS-$(CONFIG_WHICH) += which.o
-
-ifneq ($(strip $(DEBIANUTILS-y)),)
-libraries-y+=$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR)
-endif
-DEBIANUTILS_SRC-y:=$(patsubst %.o,$(srcdir)/%.c,$(DEBIANUTILS-y))
-DEBIANUTILS_SRC-a:=$(wildcard $(srcdir)/*.c)
-APPLET_SRC-y+=$(DEBIANUTILS_SRC-y)
-APPLET_SRC-a+=$(DEBIANUTILS_SRC-a)
-
-$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR): $(patsubst %,$(DEBIANUTILS_DIR)%, $(DEBIANUTILS-y))
- $(do_ar)
-
-$(DEBIANUTILS_DIR)%.o: $(srcdir)/%.c
- $(compile.c)