aboutsummaryrefslogtreecommitdiff
path: root/examples/busybox.spec
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>1999-10-05 16:24:54 +0000
committerEric Andersen <andersen@codepoet.org>1999-10-05 16:24:54 +0000
commitcc8ed39b240180b58810784f844e253263594ac3 (patch)
tree15feebbb4be9a9168209609f48f0b100f9364420 /examples/busybox.spec
downloadbusybox-cc8ed39b240180b58810784f844e253263594ac3.tar.gz
Initial revision
Diffstat (limited to 'examples/busybox.spec')
-rw-r--r--examples/busybox.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/examples/busybox.spec b/examples/busybox.spec
new file mode 100644
index 000000000..46bd7f484
--- /dev/null
+++ b/examples/busybox.spec
@@ -0,0 +1,43 @@
+Name: busybox
+Version: 0.29alpha
+Release: 1
+Group: System/Utilities
+Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
+Copyright: GPL
+Packager : Erik Andersen <andersen@lineo.com>
+Conflicts: fileutils grep shellutils
+Buildroot: /tmp/%{Name}-%{Version}
+Source: busybox-0.29a1.tar.gz
+
+%Description
+BusyBox is a suite of "tiny" Unix utilities in a multi-call binary. It
+provides a pretty complete environment that fits on a floppy or in a
+ROM. Just add "ash" (Keith Almquists tiny Bourne shell clone) and "ae",
+and a kernel and you have a full system. This is used on the Debian
+install disk and in an internet router, and it makes a good environment
+for a "rescue" disk or any small or embedded system.
+
+%Prep
+%setup -q -n busybox
+
+%Build
+make
+
+%Install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/bin
+h=`cat busybox.links`
+
+for i in $h ; do
+ mkdir -p $RPM_BUILD_ROOT/`echo $i | sed -e 's/\(^.*\/\)\(.*\)/\1/g' `
+ (cd $RPM_BUILD_ROOT/bin ; ln -s ln `echo $i | sed -e 's/\(^.*\/\)\(.*\)/\2/g' ` );
+done
+rm -f $RPM_BUILD_ROOT/bin/ln
+install -m 755 busybox $RPM_BUILD_ROOT/bin/ln
+
+%Clean
+rm -rf $RPM_BUILD_ROOT
+
+%Files
+%defattr(-,root,root)
+/