aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 16 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b812bc249..2a0b48f24 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,6 +21,7 @@ busybox-deb:
$(MAKE)
install -D busybox ./debian/busybox/bin/busybox
dh_installchangelogs Changelog -pbusybox
+ dh_installdocs -pbusybox
dh_strip -pbusybox
dh_compress -pbusybox
dh_fixperms -pbusybox
@@ -58,6 +59,7 @@ busybox-static:
$(MAKE)
install -D busybox ./debian/busybox-static/bin/busybox
dh_installchangelogs Changelog -pbusybox-static
+ dh_installdocs -pbusybox-static
dh_strip -pbusybox-static
dh_compress -pbusybox-static
dh_fixperms -pbusybox-static
@@ -69,5 +71,19 @@ busybox-static:
binary-arch: busybox-deb busybox-udeb busybox-static
+binary-indep:
+ dh_testdir
+ dh_testroot
+ $(MAKE) clean
+ $(MAKE) newdoc
+ dh_installdocs -pbusybox-doc
+ dh_installchangelogs Changelog -pbusybox-doc
+ dh_compress -pbusybox-doc
+ dh_fixperms -pbusybox-doc
+ dh_installdeb -pbusybox-doc
+ dh_gencontrol -pbusybox-doc
+ dh_md5sums -pbusybox-doc
+ dh_builddeb -pbusybox-doc
+
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure