aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorsomini <dev@somini.xyz>2020-12-03 00:18:05 +0000
committerHarry Jeffery <harry@exec64.co.uk>2021-07-08 23:30:24 +0100
commit38eee61bebf266af1ae5b652508134ce613295c5 (patch)
treeed92e90c83a2fe8f12b107be2ff3c396ee8c4440 /meson.build
parenteccd3cf9124d4ff2f4569b0c1fbf7f3a7b008b4d (diff)
downloadimv-38eee61bebf266af1ae5b652508134ce613295c5.tar.gz
Include support for imv-folder
This is a wrapper to open all images in a folder. Includes: - Script itself - Man page - Desktop file - Necessary Makefile changes Fix #223
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 14 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 73137c9..41a4616 100644
--- a/meson.build
+++ b/meson.build
@@ -155,6 +155,12 @@ foreach ws : ['wayland', 'x11']
endif
endforeach
+install_data(
+ files('files/imv-folder'),
+ install_dir: get_option('bindir'),
+ install_mode: 'rwxr-xr-x',
+)
+
if not target_single_ws
install_data(
files('files/imv'),
@@ -163,11 +169,13 @@ if not target_single_ws
)
endif
-install_data(
- files('files/imv.desktop'),
- install_dir: '@0@/applications'.format(get_option('datadir')),
- install_mode: 'rw-r--r--',
-)
+foreach desktop: ['imv', 'imv-folder']
+ install_data(
+ files('files/@0@.desktop'.format(desktop)),
+ install_dir: '@0@/applications'.format(get_option('datadir')),
+ install_mode: 'rw-r--r--',
+ )
+endforeach
install_data(
files('files/imv_config'),
@@ -196,6 +204,7 @@ prog_a2x = find_program('a2x', required: get_option('man'))
if prog_a2x.found()
foreach man : [
[1, 'imv'],
+ [1, 'imv-folder'],
[1, 'imv-msg'],
[5, 'imv'],
]