aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStephan Lachnit <stephanlachnit@protonmail.com>2020-02-28 10:41:01 +0100
committerHarry Jeffery <harry@exec64.co.uk>2020-12-02 00:19:14 +0000
commit84a1f7aa83326f1e4aac20e02d81f9c8dc4d5310 (patch)
treee4e6c2066fc389be4c833663cc136a277f167f3d /meson.build
parent82960d3c41601652860843c1040acaf7860d79d0 (diff)
downloadimv-84a1f7aa83326f1e4aac20e02d81f9c8dc4d5310.tar.gz
Use system inih if available
* inih is now widely available as a system library * if not, a fallback from Wrap DB can be used Signed-off-by: Stephan Lachnit <stephanlachnit@protonmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 672ba1a..386d0ea 100644
--- a/meson.build
+++ b/meson.build
@@ -43,6 +43,7 @@ deps_for_imv = [
dependency('threads'),
dependency('xkbcommon'),
dependency('icu-io'),
+ dependency('inih', fallback : ['inih', 'inih_dep']),
]
files_common = files(
@@ -53,7 +54,6 @@ files_common = files(
'src/console.c',
'src/image.c',
'src/imv.c',
- 'src/ini.c',
'src/ipc.c',
'src/ipc_common.c',
'src/keyboard.c',