aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2001-07-06 20:36:57 +0000
committerEric Andersen <andersen@codepoet.org>2001-07-06 20:36:57 +0000
commit0279505e8c837c59b6a777d40a58ee1a399d19da (patch)
treef41709c3f0f248ad7aee5de48696c50e567197bc /debian/rules
parentd28cb03819352b6f0472994f1aa342910e6d638c (diff)
downloadbusybox-0279505e8c837c59b6a777d40a58ee1a399d19da.tar.gz
Update the debian packaging stuff
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 2 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 5271b97fd..1d7413c35 100755
--- a/debian/rules
+++ b/debian/rules
@@ -84,10 +84,9 @@ do_static: half_clean build-static install-static
# Now for the .udeb stuff
PACKAGE=busybox-udeb
-VERSION=$(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2)
+VERSION=$(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2 | sed -e s/[0-9]://g)
ARCH=$(shell dpkg --print-architecture)
FILENAME=$(PACKAGE)_$(VERSION)_$(ARCH).udeb
-PRIORITY=$(shell grep ^Priority: debian/control | cut -d ' ' -f 2)
build-udeb: debian/build-stamp-busybox-udeb
debian/build-stamp-busybox-udeb:
@@ -186,7 +185,7 @@ busybox-udeb: do_udeb
# Don't write your stupid guesses to debian/files.
dh_gencontrol -p$@ -- -fdebian/files~
# Register file manually.
- dpkg-distaddfile $(FILENAME) debian-installer $(PRIORITY)
+ dpkg-distaddfile $(FILENAME) debian-installer standard
dh_md5sums -p$@
dh_builddeb -p$@ --filename=$(FILENAME)