aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2000-12-13 16:42:24 +0000
committerEric Andersen <andersen@codepoet.org>2000-12-13 16:42:24 +0000
commit46948366fa20d2fe979a7af887863a0800e24579 (patch)
tree39bc504da8797244cbf09ec544575abdbaa5cf54 /debian
parent21125543e189a88ae98a48248014839db40f4d61 (diff)
downloadbusybox-46948366fa20d2fe979a7af887863a0800e24579.tar.gz
Update the version number to 0.48 (no longer pre).
Diffstat (limited to 'debian')
-rw-r--r--debian/Config.h-deb40
-rw-r--r--debian/changelog16
2 files changed, 31 insertions, 25 deletions
diff --git a/debian/Config.h-deb b/debian/Config.h-deb
index fe4e10fdd..c156d949c 100644
--- a/debian/Config.h-deb
+++ b/debian/Config.h-deb
@@ -165,7 +165,7 @@
// enable ls -p and -F
#define BB_FEATURE_LS_FILETYPES
//
-// sort the file names (still a bit buggy)
+// sort the file names
#define BB_FEATURE_LS_SORTFILES
//
// enable ls -R
@@ -178,7 +178,7 @@
//#define BB_FEATURE_SIMPLE_PING
//
// Make init use a simplified /etc/inittab file (recommended).
-//#define BB_FEATURE_USE_INITTAB
+#define BB_FEATURE_USE_INITTAB
//
//Enable init being called as /linuxrc
#define BB_FEATURE_LINUXRC
@@ -192,7 +192,7 @@
//#define BB_FEATURE_INIT_CHROOT
//
//Make sure nothing is printed to the console on boot
-//#define BB_FEATURE_EXTRA_QUIET
+#define BB_FEATURE_EXTRA_QUIET
//
//Should syslogd also provide klogd support?
#define BB_FEATURE_KLOGD
@@ -210,7 +210,9 @@
// Enable support for a real /etc/mtab file instead of /proc/mounts
//#define BB_FEATURE_MOUNT_MTAB_SUPPORT
//
-// Enable support for mounting remote NFS volumes
+// Enable support for mounting remote NFS volumes.
+// You may need to mount with "-o nolock" if you are
+// not running a local portmapper daemon...
#define BB_FEATURE_NFSMOUNT
//
// Enable support forced filesystem unmounting
@@ -220,27 +222,30 @@
// Enable support for creation of tar files.
#define BB_FEATURE_TAR_CREATE
//
-// Enable support for "--exclude" for excluding files
+// Enable support for "--exclude" and "-X" for excluding files
#define BB_FEATURE_TAR_EXCLUDE
//
+// Enable support for tar -z option (currently only works for inflating)
+#define BB_FEATURE_TAR_GZIP
+//
//// Enable reverse sort
#define BB_FEATURE_SORT_REVERSE
//
// Enable command line editing in the shell
#define BB_FEATURE_SH_COMMAND_EDITING
//
-//Allow the shell to invoke all the compiled in BusyBox commands as if they
-//were shell builtins. Nice for staticly linking an emergency rescue shell
-//among other thing.
+//Allow the shell to invoke all the compiled in BusyBox applets as if they
+//were shell builtins. Nice for staticly linking an emergency rescue shell,
+//among other things.
#define BB_FEATURE_SH_STANDALONE_SHELL
//
-//When this is enabled, busybox shell builtins can be called using full path
-//names. This causes builtins (i.e. every single busybox command) to override
+//When this is enabled, busybox shell applets can be called using full path
+//names. This causes applets (i.e., most busybox commands) to override
//real commands on the filesystem. For example, if you run run /bin/cat, it
//will use BusyBox cat even if /bin/cat exists on the filesystem and is _not_
//busybox. Some systems want this, others do not. Choose wisely. :-) This
//only has meaning when BB_FEATURE_SH_STANDALONE_SHELL is enabled.
-#define BB_FEATURE_SH_BUILTINS_ALWAYS_WIN
+//BB_FEATURE_SH_APPLETS_ALWAYS_WIN
//
// Enable tab completion in the shell (not yet
// working very well -- so don't turn this on)
@@ -270,13 +275,14 @@
// Support for Minix filesystem, version 2
//#define BB_FEATURE_MINIX2
//
+//
// Enable busybox --install [-s]
// to create links (or symlinks) for all the commands that are
// compiled into the binary. (needs /proc filesystem)
-#define BB_FEATURE_INSTALLER
+// #define BB_FEATURE_INSTALLER
//
// Enable a nifty progress meter in wget (adds just under 2k)
-#define BB_FEATURE_STATUSBAR
+//#define BB_FEATURE_STATUSBAR
//
// Clean up all memory before exiting -- usually not needed
// as the OS can clean up... Don't enable this unless you
@@ -321,6 +327,14 @@
#endif
#endif
//
+#ifdef BB_TAR
+#ifdef BB_FEATURE_TAR_GZIP
+#ifndef BB_GUNZIP
+#define BB_GUNZIP
+#endif
+#endif
+#endif
+//
#if defined BB_MOUNT && defined BB_FEATURE_NFSMOUNT
#define BB_NFSMOUNT
#endif
diff --git a/debian/changelog b/debian/changelog
index 6ca8de50a..5e68269d3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,18 +1,10 @@
-busybox (0.48pre-2) unstable; urgency=low
+busybox (0.48-1) unstable; urgency=low
* Lots more source updates and bug fixes. See changelog for details.
+ * Now includes .udeb support for the debian-installer. The .udeb
+ probably needs some more work, but this should be a good start.
- -- Erik Andersen <andersee@debian.org> Sat, 9 Dec 2000 21:42:57 -0700
-
-busybox (0.48pre-1) unstable; urgency=low
-
- * Now includes .udeb support for the debian-installer -- note that this
- is not really a released version of BusyBox (though the code is quite
- solid). I'm just getting the .udeb support out there to facilitate
- further work on the debian-installer.
- * See changelog for details.
-
- -- Erik Andersen <andersee@debian.org> Fri, 1 Dec 2000 15:39:30 -0700
+ -- Erik Andersen <andersee@debian.org> Wed, 13 Dec 2000 08:36:07 -0700
busybox (0.47-1) unstable; urgency=low