aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2001-04-09 18:42:52 +0000
committerEric Andersen <andersen@codepoet.org>2001-04-09 18:42:52 +0000
commit5d6f3440e6a5e0436790886ccfdc023d61bdff56 (patch)
treec7bed067cea2410bf18bb1ae14d8e8372c2d59df /debian
parent305fdfa755c94bdbe54fb9bd3db2f51086f9f2d3 (diff)
downloadbusybox-5d6f3440e6a5e0436790886ccfdc023d61bdff56.tar.gz
use 'USE_SYSTEM_PWD_GRP=false' for the Debian packages so the boot-floppies
do not need any of the nss crap installed. As was, things like 'id' would fail. Fixed now (with thanks to Matt Kraai for his help). -Erik
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 98bdf0ea6..5271b97fd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,7 +29,7 @@ debian/build-stamp-busybox:
cp Makefile $(bbbd)
cp debian/Config.h-deb $(bbbd)/Config.h
-(cd $(bbbd); $(MAKE) "BB_SRC_DIR=../../" applet_source_list)
- (cd $(bbbd); $(MAKE) "BB_SRC_DIR=../../")
+ (cd $(bbbd); $(MAKE) USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
touch debian/build-stamp-busybox
install: build
@@ -54,7 +54,7 @@ debian/build-stamp-busybox-static:
mkdir -p $(bbsbd)
cp Makefile $(bbsbd)
cp debian/Config.h-static $(bbsbd)/Config.h
- (cd $(bbsbd); $(MAKE) DOSTATIC=true "BB_SRC_DIR=../../")
+ (cd $(bbsbd); $(MAKE) DOSTATIC=true USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
touch debian/build-stamp-busybox-static
install-static: build
@@ -95,7 +95,7 @@ debian/build-stamp-busybox-udeb:
mkdir -p $(bbubd)
cp Makefile $(bbubd)
cp debian/Config.h-udeb $(bbubd)/Config.h
- (cd $(bbubd); $(MAKE) "BB_SRC_DIR=../../")
+ (cd $(bbubd); $(MAKE) USE_SYSTEM_PWD_GRP=false "BB_SRC_DIR=../../")
touch debian/build-stamp-busybox-udeb
install-udeb: build