aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2003-07-22 22:15:21 +0000
committerEric Andersen <andersen@codepoet.org>2003-07-22 22:15:21 +0000
commite5272074c9bf554fa9f24a97899de584b1c127c2 (patch)
treeb2cb25c7af226c471111fd04f14e7502f41b1155 /debian
parent20c9f1e5e7290c7d22bdf4217e66b9d75e9e73df (diff)
downloadbusybox-e5272074c9bf554fa9f24a97899de584b1c127c2.tar.gz
eliminate DOSTATIC, DODEBUG, etc and name them sensibly
Diffstat (limited to 'debian')
-rw-r--r--debian/config-deb6
-rw-r--r--debian/config-net-udeb6
-rw-r--r--debian/config-net-udeb-i3866
-rw-r--r--debian/config-static6
-rw-r--r--debian/config-udeb6
-rw-r--r--debian/config-udeb-i3866
-rwxr-xr-xdebian/rules10
7 files changed, 23 insertions, 23 deletions
diff --git a/debian/config-deb b/debian/config-deb
index 862e06f1f..4d63e690f 100644
--- a/debian/config-deb
+++ b/debian/config-deb
@@ -20,8 +20,8 @@ CONFIG_FEATURE_INSTALLER=y
#
# Build Options
#
-# DOSTATIC is not set
-DOLFS=y
+# CONFIG_STATIC is not set
+CONFIG_LFS=y
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -362,4 +362,4 @@ CONFIG_FEATURE_MOUNT_LOOP=y
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/config-net-udeb b/debian/config-net-udeb
index 0a7990cf5..b9426a2a3 100644
--- a/debian/config-net-udeb
+++ b/debian/config-net-udeb
@@ -20,8 +20,8 @@ CONFIG_FEATURE_DEVPTS=y
#
# Build Options
#
-# DOSTATIC is not set
-# DOLFS is not set
+# CONFIG_STATIC is not set
+# CONFIG_LFS is not set
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -366,4 +366,4 @@ CONFIG_UMOUNT=y
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/config-net-udeb-i386 b/debian/config-net-udeb-i386
index d82fabb94..1335bac01 100644
--- a/debian/config-net-udeb-i386
+++ b/debian/config-net-udeb-i386
@@ -20,8 +20,8 @@ CONFIG_FEATURE_DEVPTS=y
#
# Build Options
#
-# DOSTATIC is not set
-DOLFS=y
+# CONFIG_STATIC is not set
+CONFIG_LFS=y
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -371,4 +371,4 @@ CONFIG_FEATURE_MOUNT_FORCE=y
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/config-static b/debian/config-static
index 082c46da9..454bbf25d 100644
--- a/debian/config-static
+++ b/debian/config-static
@@ -20,8 +20,8 @@ CONFIG_FEATURE_DEVPTS=y
#
# Build Options
#
-DOSTATIC=y
-DOLFS=y
+CONFIG_STATIC=y
+CONFIG_LFS=y
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -486,4 +486,4 @@ CONFIG_FEATURE_MTAB_FILENAME="/etc/mtab"
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/config-udeb b/debian/config-udeb
index be119aa3e..b78c6a583 100644
--- a/debian/config-udeb
+++ b/debian/config-udeb
@@ -20,8 +20,8 @@ CONFIG_FEATURE_DEVPTS=y
#
# Build Options
#
-# DOSTATIC is not set
-DOLFS=y
+# CONFIG_STATIC is not set
+CONFIG_LFS=y
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -398,4 +398,4 @@ CONFIG_FEATURE_MOUNT_FORCE=y
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/config-udeb-i386 b/debian/config-udeb-i386
index e12e8c178..72fc4c342 100644
--- a/debian/config-udeb-i386
+++ b/debian/config-udeb-i386
@@ -20,8 +20,8 @@ CONFIG_FEATURE_DEVPTS=y
#
# Build Options
#
-# DOSTATIC is not set
-DOLFS=y
+# CONFIG_STATIC is not set
+CONFIG_LFS=y
# USING_CROSS_COMPILER is not set
EXTRA_CFLAGS_OPTIONS=""
@@ -410,4 +410,4 @@ CONFIG_FEATURE_MOUNT_FORCE=y
#
# Debugging Options
#
-# DODEBUG is not set
+# CONFIG_DEBUG is not set
diff --git a/debian/rules b/debian/rules
index 47605fa71..82bf9f04a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
VERSION = $(shell dpkg-parsechangelog | grep ^Version: | cut -d ' ' -f 2)
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- DODEBUG = true
+ CONFIG_DEBUG = true
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
endif
@@ -39,7 +39,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
install -d install-$(PACKAGE_PREFIX)/bin
install busybox install-$(PACKAGE_PREFIX)/bin/busybox
@@ -57,7 +57,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
install -d install-$(PACKAGE_PREFIX)-static/bin
install busybox install-$(PACKAGE_PREFIX)-static/bin/busybox
@@ -75,7 +75,7 @@ else
endif
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
$(MAKE) PREFIX=$(CURDIR)/install-$(PACKAGE_PREFIX)-udeb install
@@ -89,7 +89,7 @@ ifneq ($(wildcard ./debian/config-net-udeb-$(DEB_HOST_ARCH)),)
cp ./debian/config-net-udeb-$(DEB_HOST_ARCH) .config
$(MAKE) dep
- $(MAKE) DODEBUG=$(DODEBUG)
+ $(MAKE) CONFIG_DEBUG=$(CONFIG_DEBUG)
$(MAKE) PREFIX=$(CURDIR)/install-$(PACKAGE_PREFIX)-net-udeb install
endif