aboutsummaryrefslogtreecommitdiff
path: root/debianutils
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-03-09 09:03:37 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-03-09 09:03:37 +0000
commit07a79e75f502ebd41e5341aacc5de303d3ffaea0 (patch)
tree4b95f98bab0b298c5df171772b629d03400ef507 /debianutils
parent874af85d5eb08b65476f406f6a1e7edc127ac210 (diff)
downloadbusybox-07a79e75f502ebd41e5341aacc5de303d3ffaea0.tar.gz
- backout using features which are not available with the previous stable
version of make (3.71.1).
Diffstat (limited to 'debianutils')
-rw-r--r--debianutils/Makefile.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in
index ffdb7abdc..4f72c233c 100644
--- a/debianutils/Makefile.in
+++ b/debianutils/Makefile.in
@@ -4,8 +4,8 @@
#
# Licensed under the GPL v2, see the file LICENSE in this tarball.
-srcdir=$(top_srcdir)/debianutils
-objdir=$(top_builddir)/debianutils
+srcdir:=$(top_srcdir)/debianutils
+objdir:=$(top_builddir)/debianutils
DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o
DEBIANUTILS-$(CONFIG_PIPE_PROGRESS) += pipe_progress.o
@@ -21,3 +21,7 @@ APPLET_SRC-a+=$(DEBIANUTILS_SRC-a)
debianutils_OBJ:= $(patsubst %,$(objdir)/%,$(DEBIANUTILS-y))
+$(debianutils_OBJ): $(objdir)/%.o: $(srcdir)/%.c
+$(objdir)/debianutils.a: $(debianutils_OBJ)
+libraries-y:=$(libraries-y) $(objdir)/debianutils.a
+