aboutsummaryrefslogtreecommitdiff
path: root/debianutils
diff options
context:
space:
mode:
authorDenis Vlasenko <vda.linux@googlemail.com>2006-10-05 10:17:08 +0000
committerDenis Vlasenko <vda.linux@googlemail.com>2006-10-05 10:17:08 +0000
commit7d219aab70e6951ab82c27c202cac05016696723 (patch)
tree4c0679bfa391f71aee9b51505a5d3dc8f60a0cf7 /debianutils
parent8f8f268cfdecb4cabeb2e649a73afc7a485aeff5 (diff)
downloadbusybox-7d219aab70e6951ab82c27c202cac05016696723.tar.gz
build system overhaul
Diffstat (limited to 'debianutils')
-rw-r--r--debianutils/Config.in28
-rw-r--r--debianutils/Kbuild13
-rw-r--r--debianutils/Makefile23
-rw-r--r--debianutils/Makefile.in33
4 files changed, 27 insertions, 70 deletions
diff --git a/debianutils/Config.in b/debianutils/Config.in
index 3dd2ef61b..3d85999ff 100644
--- a/debianutils/Config.in
+++ b/debianutils/Config.in
@@ -5,33 +5,33 @@
menu "Debian Utilities"
-config CONFIG_MKTEMP
+config MKTEMP
bool "mktemp"
default n
help
mktemp is used to create unique temporary files
-config CONFIG_PIPE_PROGRESS
+config PIPE_PROGRESS
bool "pipe_progress"
default n
help
Display a dot to indicate pipe activity.
-config CONFIG_READLINK
+config READLINK
bool "readlink"
default n
help
This program reads a symbolic link and returns the name
of the file it points to
-config CONFIG_FEATURE_READLINK_FOLLOW
+config FEATURE_READLINK_FOLLOW
bool "Enable canonicalization by following all symlinks (-f)"
default n
- depends on CONFIG_READLINK
+ depends on READLINK
help
Enable the readlink option (-f).
-config CONFIG_RUN_PARTS
+config RUN_PARTS
bool "run-parts"
default n
help
@@ -46,14 +46,14 @@ config CONFIG_RUN_PARTS
Unless you know that run-parts is used in some of your scripts
you can safely say N here.
-config CONFIG_FEATURE_RUN_PARTS_LONG_OPTIONS
+config FEATURE_RUN_PARTS_LONG_OPTIONS
bool "Enable long options"
default n
- depends on CONFIG_RUN_PARTS && CONFIG_GETOPT_LONG
+ depends on RUN_PARTS && GETOPT_LONG
help
Support long options for the run-parts applet.
-config CONFIG_START_STOP_DAEMON
+config START_STOP_DAEMON
bool "start-stop-daemon"
default y
help
@@ -61,23 +61,23 @@ config CONFIG_START_STOP_DAEMON
termination of system-level processes, usually the ones
started during the startup of the system.
-config CONFIG_FEATURE_START_STOP_DAEMON_FANCY
+config FEATURE_START_STOP_DAEMON_FANCY
bool "Support additional arguments"
default y
- depends on CONFIG_START_STOP_DAEMON
+ depends on START_STOP_DAEMON
help
Support additional arguments.
-o|--oknodo ignored since we exit with 0 anyway
-v|--verbose
-config CONFIG_FEATURE_START_STOP_DAEMON_LONG_OPTIONS
+config FEATURE_START_STOP_DAEMON_LONG_OPTIONS
bool "Enable long options"
default n
- depends on CONFIG_START_STOP_DAEMON && CONFIG_GETOPT_LONG
+ depends on START_STOP_DAEMON && GETOPT_LONG
help
Support long options for the start-stop-daemon applet.
-config CONFIG_WHICH
+config WHICH
bool "which"
default n
help
diff --git a/debianutils/Kbuild b/debianutils/Kbuild
new file mode 100644
index 000000000..99df6a536
--- /dev/null
+++ b/debianutils/Kbuild
@@ -0,0 +1,13 @@
+# Makefile for busybox
+#
+# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
+#
+# Licensed under the GPL v2, see the file LICENSE in this tarball.
+
+lib-y:=
+lib-$(CONFIG_MKTEMP) += mktemp.o
+lib-$(CONFIG_PIPE_PROGRESS) += pipe_progress.o
+lib-$(CONFIG_READLINK) += readlink.o
+lib-$(CONFIG_RUN_PARTS) += run_parts.o
+lib-$(CONFIG_START_STOP_DAEMON) += start_stop_daemon.o
+lib-$(CONFIG_WHICH) += which.o
diff --git a/debianutils/Makefile b/debianutils/Makefile
deleted file mode 100644
index 3d240b7bc..000000000
--- a/debianutils/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# Makefile for busybox
-#
-# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
-#
-# Licensed under the GPL v2, see the file LICENSE in this tarball.
-
-ifndef top_srcdir
-top_srcdir=..
-endif
-ifndef top_builddir
-top_builddir=..
-endif
-srcdir=$(top_srcdir)/debianutils
-DEBIANUTILS_DIR:=./
-include $(top_srcdir)/Rules.mak
-include $(top_builddir)/.config
-include $(srcdir)/Makefile.in
-all: $(libraries-y)
--include $(top_builddir)/.depend
-
-clean:
- rm -f *.o *.a $(AR_TARGET)
-
diff --git a/debianutils/Makefile.in b/debianutils/Makefile.in
deleted file mode 100644
index 2983565b8..000000000
--- a/debianutils/Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
-# Makefile for busybox
-#
-# Copyright (C) 1999-2005 by Erik Andersen <andersen@codepoet.org>
-#
-# Licensed under the GPL v2, see the file LICENSE in this tarball.
-
-DEBIANUTILS_AR:=debianutils.a
-ifndef $(DEBIANUTILS_DIR)
-DEBIANUTILS_DIR:=$(top_builddir)/debianutils/
-endif
-srcdir=$(top_srcdir)/debianutils
-
-DEBIANUTILS-y:=
-DEBIANUTILS-$(CONFIG_MKTEMP) += mktemp.o
-DEBIANUTILS-$(CONFIG_PIPE_PROGRESS) += pipe_progress.o
-DEBIANUTILS-$(CONFIG_READLINK) += readlink.o
-DEBIANUTILS-$(CONFIG_RUN_PARTS) += run_parts.o
-DEBIANUTILS-$(CONFIG_START_STOP_DAEMON) += start_stop_daemon.o
-DEBIANUTILS-$(CONFIG_WHICH) += which.o
-
-ifneq ($(strip $(DEBIANUTILS-y)),)
-libraries-y+=$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR)
-endif
-DEBIANUTILS_SRC-y:=$(patsubst %.o,$(srcdir)/%.c,$(DEBIANUTILS-y))
-DEBIANUTILS_SRC-a:=$(wildcard $(srcdir)/*.c)
-APPLET_SRC-y+=$(DEBIANUTILS_SRC-y)
-APPLET_SRC-a+=$(DEBIANUTILS_SRC-a)
-
-$(DEBIANUTILS_DIR)$(DEBIANUTILS_AR): $(patsubst %,$(DEBIANUTILS_DIR)%, $(DEBIANUTILS-y))
- $(do_ar)
-
-$(DEBIANUTILS_DIR)%.o: $(srcdir)/%.c
- $(compile.c)