aboutsummaryrefslogtreecommitdiff
path: root/examples/busybox.spec
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2001-07-09 18:34:12 +0000
committerEric Andersen <andersen@codepoet.org>2001-07-09 18:34:12 +0000
commitf52947ba71cafc771a5858ee2347f31e724376fc (patch)
treefe71b3d54b65f9a0430a66990981c6fe92cf3251 /examples/busybox.spec
parentaa64ba459f2e77d30f73dfaf0512c97cd1ce9f14 (diff)
downloadbusybox-f52947ba71cafc771a5858ee2347f31e724376fc.tar.gz
Fix the spec file so it works on redhat systems. At least I think
it will work on redhat. At least it now works on my Debian box... -Erik
Diffstat (limited to 'examples/busybox.spec')
-rw-r--r--examples/busybox.spec24
1 files changed, 16 insertions, 8 deletions
diff --git a/examples/busybox.spec b/examples/busybox.spec
index d1aea5f8c..f3c2b734d 100644
--- a/examples/busybox.spec
+++ b/examples/busybox.spec
@@ -1,13 +1,21 @@
-Name: busybox
-Version: 0.52
-Release: 1
+%define name busybox
+%define epoch 0
+%define version 0.52
+%define release %(date -I | sed -e 's/-/_/g')
+%define serial 1
+
+Name: %{name}
+#Epoch: %{epoch}
+Version: %{version}
+Release: %{release}
+Serial: %{serial}
+Copyright: GPL
Group: System/Utilities
Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
-Copyright: GPL
+URL: http://busybox.lineo.com/
+Source: ftp://oss.lineo.com/busybox/%{name}-%{version}.tar.gz
+Buildroot: /var/tmp/%{name}-%{version}
Packager : Erik Andersen <andersen@lineo.com>
-Conflicts: fileutils grep shellutils
-Buildroot: /tmp/%{Name}-%{Version}
-Source: %{Name}-%{Version}.tar.gz
%Description
BusyBox combines tiny versions of many common UNIX utilities into a single
@@ -19,7 +27,7 @@ their full featured GNU cousins; however, the options that are provided behave
very much like their GNU counterparts.
%Prep
-%setup -q -n %{Name}-%{Version}
+%setup -q -n %{name}-%{version}
%Build
make