aboutsummaryrefslogtreecommitdiff
path: root/.builds/debian.yml
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-12-23 21:41:44 +0000
committerHarry Jeffery <harry@exec64.co.uk>2020-02-08 00:29:25 +0000
commit2dd0c1469e2d87c5263fb513c331b82617ca2e12 (patch)
tree0226fc605fea293dd9950cf6cef681cc9570f108 /.builds/debian.yml
parentd75b2bc13a427367948a6bb60e46fd586d56f678 (diff)
downloadimv-2dd0c1469e2d87c5263fb513c331b82617ca2e12.tar.gz
test meson in the CI
Diffstat (limited to '.builds/debian.yml')
-rw-r--r--.builds/debian.yml15
1 files changed, 13 insertions, 2 deletions
diff --git a/.builds/debian.yml b/.builds/debian.yml
index 35acb08..2a379ac 100644
--- a/.builds/debian.yml
+++ b/.builds/debian.yml
@@ -18,6 +18,7 @@ packages:
- libxkbcommon-dev
- libxkbcommon-x11-dev
- mesa-common-dev
+ - meson
sources:
- https://git.sr.ht/~exec64/imv
tasks:
@@ -27,11 +28,21 @@ tasks:
# libnsgif isn't packaged by debian
sed -i -e 's/BACKEND_LIBNSGIF=yes/BACKEND_LIBNSGIF=no/' config.mk
cat config.mk
- - gcc: |
+ - make_gcc: |
cd imv
CC=gcc BUILDDIR=gcc make
CC=gcc BUILDDIR=gcc make check
- - clang: |
+ - make_clang: |
cd imv
CC=clang BUILDDIR=clang make
CC=clang BUILDDIR=clang make check
+#FIXME:
+# the old meson package in debian has a bug and crashes with
+# our meson.build; re-enable this once debian packages a version
+# newer than 0.49.2
+# - meson_gcc: |
+# CC=gcc meson imv build_gcc -D auto_features=enabled -D libnsgif=disabled
+# CC=gcc ninja -C build_gcc test
+# - meson_clang: |
+# CC=clang meson imv build_clang -D auto_features=enabled -D libnsgif=disabled
+# CC=clang ninja -C build_clang test