aboutsummaryrefslogtreecommitdiff
path: root/community/mpd/files/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'community/mpd/files/meson.build')
-rw-r--r--community/mpd/files/meson.build31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/mpd/files/meson.build b/community/mpd/files/meson.build
new file mode 100644
index 00000000..21e1f2e2
--- /dev/null
+++ b/community/mpd/files/meson.build
@@ -0,0 +1,31 @@
+project('fmt', 'cpp', version: '9.1.0', license: 'BSD', default_options: ['cpp_std=c++14'])
+
+fmt_private_cpp_args = []
+fmt_interface_cpp_args = []
+if get_option('default_library') == 'shared'
+ fmt_private_cpp_args += ['-DFMT_EXPORT']
+ fmt_interface_cpp_args += ['-DFMT_SHARED']
+endif
+
+fmt_lib = library(
+ 'fmt',
+ 'src/format.cc',
+ 'src/os.cc',
+ cpp_args: fmt_private_cpp_args,
+ include_directories: 'include',
+)
+
+fmt_dep = declare_dependency(
+ include_directories: 'include',
+ compile_args: fmt_interface_cpp_args,
+ link_with: fmt_lib,
+)
+
+if meson.version().version_compare('>=0.54.0')
+ meson.override_dependency('fmt', fmt_dep)
+endif
+
+fmt_header_only_dep = declare_dependency(
+ include_directories: 'include',
+ compile_args: '-DFMT_HEADER_ONLY',
+)